Instalar driver ATI radeon en openUSE Linux

La información en esta noticia proviene de Bruno Friedmann, de una entrada en su blog en opensuse.org

A partir de junio, con la versión AMD Catalyst 12.6 los chipsets gráficos compatibles con los controladores fglrx (8.980) y fglrx-legacy (8.97.100) han cambiado. Las tarjetas de las series Radeon HD 2000/3000/4000 ya no tienen apoyo del controlador fglrx estándar sino de la versión fglrx-legacy. Esto significa que los propietarios de estas tarjetas tendrán que cambiar el controlador a partir de ahora. Aquí es donde las cosas se ponen complicadas: no se pueden instalar ambos controladores a la vez. Es uno u otro, no ambos a la vez. Además cada controlador ha de estar en un repositorio diferente. Efectos secundarios: no se puede operar en el mismo sistema dos tarjetas de AMD/ATI con dos controladores diferentes.

La buena noticia es que ambas versiones del controlador son compatibles con los nuevos kernels 3.4 y 3.5, y por tanto soportan las versiones 12.1 y 12.2 de openSUSE. Así que durante al menos dos años las tarjetas Radeon HD 2000/3000/4000 tendrán el apoyo no oficial de openSUSE. Sin embargo, hay que tener en cuenta que el controlador legado solo es mantenido por AMD por compatibilidad, para corregir errores, pero no para seguir incorporándole características. Esto puede significar, entre otras cosas, que la próxima versión de GNOME o KDE se ejecutará con los efectos 3D activados o no, especialmente cuando dicho escritorio se actualiza desde un repositorio no oficial o desde el repositorio Tumbleweed.

En resumen, para openSUSE 11.3 y versiones siguientes:

Para una tarjeta Radon HD 5xxx:

Hay que instalar el controlador estándar de fglrx.
Hay que utilizar el nuevo repositorio http://geeko.ioda.net/mirror/amd-fglrx/

Para una tarjeta Radeon HD 2xxx, HD 3xxx, HD 4xxx:

Hay que utlizar el controlador fglrx-legacy.
Hay que utlilizar el nuevo repositorio http://geeko.ioda.net/mirror/amd-fglrx-legacy/

Antes de instalar las nuevas versiones, hay que eliminar las versiones anteriores del controlador con Yast o zypper. Ejecutar como root:

zypper rm fgrlx

También conviene eliminar todos los rastros de las versiones anteriores de los controladores. Ejecutar como root:

# Eliminar versión anterior del archivo de configuración
rm -fr /etc/ati

# Eliminar versión anterior del módulo del controlador
find /lib/modules -type f -iname "fglrx.ko" -exec rm -fv {} \;

Para saber si el sistema es de 32 bits o 64 bits ejecutar:
uname -a

Espero que la información les sea útil a todos los "infelices" propietarios de targetas "descatalogadas" como yo. Ya he instalado la versión fglrx-legacy en mi openSUSE 12.2 RC2 sin problemas siguiendo las instrucciones que he descrito.

Un saludo.

fuente:http://www.forosuse.org/forosuse/showthread.php?p=156309#post156309

Instalar driver ati radeon en opensuse linux

La forma fácil de instalar los controladores propietarios de ATI tiene la ventaja de ser fácil y no requiere que se vuelva a compilar el módulo del kernel cuando éste sea actualizado. Tenga en cuenta que muchas de las tarjetas ATI antiguas están muy bien soportadas por el controlador libre. Si tienes alguna de éstas, considera seguir usando ese controlador.

Antes de usar estos controladores, trata de ejecutar una aplicación 3D usando el controlador libre: radeon (para tarjetas antiguas) y radeonhd (para las tarjetas más modernas).

 

Controlador gráfico de AMD/ATI

Dialogo advertencia 64x64.png No hay controlador gráfico de AMD/ATI para las tarjetas de las series HD4xxx o inferiores a partir de openSUSE 12.3, solo se podrá usar el controlador libre (radeon) con ellas. El motivo es que estas series han dejado de recibir soporte de AMD/ATI y el controlador existente para ellas no es compatible con X.Org 1.13 o superior.

Usar repositorios

Esto está orientado a gente que prefiere no usar el 1-click install, para que puedan hacerlo de la forma directa y ver lo que está ocurriendo.

Prerrequisitos

  • Ser capaz de usar el gestor de paquetes YaST o zypper
  • Conocer la versión del kernel que usas (default, pae, ...), pon 'uname -r' en la consola

Añadir el repositorio de ATI

  • Para tarjetas de la serie HD5xxx o superior

Instalación

Ahora instala el siguiente paquete con YaST o zypper:

  • x11-video-fglrxG02 (para las series HD2000 y posteriores)
  • x11-video-fglrxG01 (para Radeon 9500 - X1900)

 

PD: probado en OpenSuse 11.2 64bits con Ati radeon HD 3200 integrada.

 

Fuente: es.opensuse.org/ATI

Etiquetas